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1 INTRODUCTION 

Important information: Read the manual carefully before using the device. Inappropriate utilization may cause 

damage to the device, to the DUT (device under test), and/or other components of  your setup.  

Keep these instructions in a safe place and pass them on to any future user.  

1.1 Conformity 

We, Image Engineering GmbH & Co. KG, hereby declare that GEOCAL/GEOCAL XL corresponds to the 

essential requirements of  the following EC directives: 

- 2011/65/EU - RoHS 2  
- 2014/35/EU - Low Voltage   
- 2014/30/EU - Electromagnetic Compatibility  

 
 

And standards or normative documents: 

 

- EN 61326-1:2013 – Electrical equipment for measurement, control, and laboratory use - EMC 
requirements - Part 1: General requirements   

- EN 61000-3-2:2014 - Electromagnetic compatibility (EMC) - Part 3-2: Limits - Limits for harmonic current 
emissions 

- EN 61000-3-3:2013 - Electromagnetic compatibility (EMC) - Part 3-3: Limits 
- EN 62471-2:2009 - Photobiological safety of  lamps and lamp systems   
- DIN EN 60825-1 - Safety of  laser products - Part 1: Equipment classif ication and requirements 

1.2 Intended use 

GEOCAL/GEOCAL XL consists of an illuminating hardware device and software for the geometric calibration of  

camera systems. The GEOCAL software is used for calculating the calibration parameters f rom a single image 

taken with a camera system of  the point grid generated by the GEOCAL hardware device. 

• Only suitable for indoor use. 

• Place the system in a dry and constant tempered environment. Avoid high air humidity. 

1.3 General safety information 

WARNING! GEOCAL/GEOCAL XL uses a laser diode for illumination.  

 

LASER RADIATION CLASS 1M LASER PRODUCT 

• Do not stare into the beam 

• Do not view directly with optical instruments 

• Do not open the housing of  GEOCAL / GEOCAL XL under any circumstances 
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2 GETTING STARTED 

2.1 Scope of delivery 

• GEOCAL or GEOCAL XL hardware device 

• The latest sof tware version on the USB storage device 

• Power supply + cable 

• USB cable (type B to type A) 

• Test report 

 

2.2 Commissioning 

• Remove the packaging material. 

• The power socket and the main power switch are located on the back side of  the device next to the 

USB type B socket. 

Connect GEOCAL/GEOCAL XL to a power outlet and switch it on.  

Please note that the blue LED next to the power switch indicates that the power line is active and that  

GEOCAL is ready for operation. 

• Install the latest GEOCAL sof tware (Windows, 64bit) 
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3 OPERATING INSTRUCTIONS HARDWARE 

3.1 GEOCAL / GEOCAL XL 

After switching on, GEOCAL/GEOCAL XL is ready for use. No warm-up phase is required. 

3.2 Diffractive Optical Element (DOE) 

A diffractive optical element (DOE) is used to split the incoming light beam and generate a calibration grid of  

evenly distributed light spots with a wavelength of  633 nm. The DOE is mounted on the f ront of  the 

GEOCAL/GEOCAL XL device (visible glass plate mounted in circular cutout, see Figure 2). 

    

 

3.3 Camera settings 

Set the camera to manual exposure mode. If  manual mode is not available, use the automatic exposure mode. 

The image should be saved in a lossless format for best results. TIFF format is recommended, and PNG and 

JPEG (lossy) are also supported. If  you convert RAW image data to another format, ensure the image is 

debayered in the process. 

The autofocus must be turned of f . Since GEOCAL / GEOCAL XL uses a collimated light beam virtually 

originating from infinity, the appropriate focus distance will be near inf inity. Using manual focus, ensure the 

camera is focused on the light points. 

Exposure program  Manual 

Aperture  No default value 

ISO Speed  Lowest value (e.g.,100) 

Autofocus  Of f  

File type  
TIFF is recommended. PNG 

and JPEG are also supported 
 

DOE 

Figure 1: Calibration grid 

(the brightest spot marks the center) 

Figure 2: Location of the DOE 
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3.3.1 Camera position and suitable lenses 

Place the camera in f ront of  the dif f ractive optical element in the circular opening on the f ront of  

GEOCAL/GEOCAL XL.  

The camera can be placed directly in front of the DOE; no minimum distance is needed (view Figure 3 below). 

The principal axis of the lens should be aligned approx. perpendicular to the DOE. Achieve this by aligning the 

0th dif fraction order, the brightest spot in the grid center, with the center of the image. See Figure 4 for reference. 

Make sure that the point grid covers the whole image and that the border of  the DOE is not visible.  

 

  

 

The top side of GEOCAL/GEOCAL XL and the top side of the camera must have the same orientation. A rotation 

of  the camera around the optical axis of  approx. +/- 2° will be tolerable. 

No further alignment steps are necessary. The camera's translation does not influence the mapping of  the light 

points. The camera rotation to the DOE is part of  the calibration and is determined during the process and 

reported as part of  the result.  

The lens's f ront element must not be larger than 77 mm in diameter for GEOCAL or 155 mm for GEOCAL XL to 

capture the point grid in full format.  

Figure 3: Setting the distance between the camera and GEOCAL/GEOCAL XL 

Figure 4: Good alignment (0
th
 order in the center of image)            Bad alignment (0

th
 order far off center) 
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Note: Please use caution when positioning the camera. The DOE is made of glass and has a 

thickness of only 1.5 mm. 

Ensure the calibration is performed in a dark environment to avoid stray light, reflections, or similar 

interfering factors.  

3.3.2 Exposure 

For best results, the exposure should be selected so that the individual light points are not saturated  (i.e., no 

white pixels or a minimal number of  white pixels in the center of  each point) with the exception of  the 0 th 

dif fraction order. The 0th order will always be much brighter than the points surrounding it. See Figure 5 below for 

an example. 

  

 

Depending on your camera, you might encounter dif ferent problems: 

The exposure time of my camera cannot be set short enough to avoid saturation.  

Possible solutions: 

- Set the ISO to the lowest native value available (ISO 100 for most cameras) 

- Stop down the aperture if  possible 

- If  the image is still too bright, you could use an ND-Filter to reduce the amount of  light reaching the 

image sensor 

The intensity drop-off is too steep towards the edges of the image, and no more points are visible. 

This problem may occur for ultra-wide-angle lenses. If  the images cannot be adequately analyzed, try the 

following. 

Generate an HDR image by taking multiple images of the point grid using a range of  exposure times (do not 

change aperture settings in this case) and combine them into a high dynamic range image to achieve more or 

less uniform exposure across the entire sensor. Do not change the camera's orientation between images 

because the points would no longer be aligned to one another through multiple images.  

Figure 5: Suitable exposure (dark background, small points)        Exposure too bright (red background, larger, saturated points) 
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4 DIFFERENCES BETWEEN GEOCAL AND GEOCAL XL 

The key difference between GEOCAL XL and the standard GEOCAL is the physical size of the dif f ractive 

optical element (DOE) that generates the point grid. While the standard GEOCAL has a usable diameter 

of  77 mm, the GEOCAL XL provides a functional diameter of  155 mm. 

 

 

4.1 Why a larger version of the GEOCAL? 

A larger DOE is needed when the device under test (DUT) cannot be placed directly in f ront of  the DOE, 

for example, when a car's windshield is involved. As mentioned in chapter 3.3.1, "Camera position and 

suitable lenses," the generated point grid needs to cover the entire camera sensor to provide a reliable 

calibration.  

 

 

Figure 6: Use case for the larger DOE provided in the GEOCAL XL 

 

 

As illustrated in Figure 6 above, the windscreen angle prevents the standard GEOCAL from being placed 

close enough to the camera to provide a full-frame image of the standard DOE. This angle would result in 

a less precise and less reliable calibration. 
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5 OPERATING INSTRUCTIONS SOFTWARE 

The GEOCAL sof tware allows you to calibrate your camera system in a matter of  seconds.  

The results can be saved as CSV or XML f iles. 

5.1 Installing GEOCAL software 

• Execute the GEOCAL installer (GEOCAL_Vx.x.x.exe, 64-bit) and follow the instructions.  

• The sof tware is now ready for use.  

5.2 Configuration file (XML format) 

Four default configuration files in XML format are provided with the software. If  your calibration procedure does 

not require special settings, you can use one of the four configuration files for the desired distortion model. You 

can modify these f iles by copying them from the install location in:  

C:\Program Files\Image Engineering\GEOCAL 1.x.x\configuration 

to some other folder, modify them and then load them with the sof tware for usage.  

See document GEOCAL_calibration_models_.pdf  for details on the usage of  the conf iguration f iles.  

Loading a config file: 

Click File → Load configuration (Ctrl+c) → navigate to the folder containing the f ile → select the f ile and click 

"open." 

5.3 Artificial sample images 

There are four sample images available, which can be found in this location: 

C:\Program Files\Image Engineering\GEOCAL 1.x.x\samples 

These images were synthetically created with the following parameters:  

Focal lengths [fx, fy]: 3030 

Skew: 0 

Tangential coefficients: 0 

Principal point [u0, v0]: [960, 752] 

DOE parameters [grating constant, wavelength]: [43.9, 0.6328] 

DOE and camera angles [Alpha, beta, omega, phi, kappa]: 0 

 

Image Model Radial coefficients [1 to 6] 

simulate_model1.png CUSTOM_MODEL_1 [1, 0.1, 0.1, 0.1, 0.1, 0.1] 

simulate_model2.png CUSTOM_MODEL_2 [1, 1, 1, 1, 1, 1] * 10
-6
 

simulate_modelf.png FISHEYE_MODEL [0.5, 0.5, 0.5, 0.5, 0.5, 0.5] 

simulate_modele.png EVEN_BROWN_MODEL [0.5, 0.5, 0.5, 0.5, 0.5, 0.5] 
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To familiarize yourself with the various models and the interactions of the parameters in the conf iguration f iles, 

you can use the default conf igurations given for each model and execute the GEOCAL sof tware on the 

simulated images.  You should obtain results that are close to those used to create the simulated images.  

5.4 Loading images for analysis 

Click File → Load images (ctrl+o) → navigate to the folder containing the images → select one or multiple 

images and click "open." 

In its current state, the sof tware supports the analysis of  8bit and 16bit images.  

The following f ile types are supported (de-bayered images): .TIFF, .JPG, .PNG 

Images for analysis must be taken so that the point grid f ills the sensor completely.  

5.5 Deleting images 

Right-click on the selected image in the list to open a delete option.  
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5.6 Image analysis 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

• Image selection: Select an image from the list in the "Image data" section (1). The image will then be 

displayed in the "Image" section (4) under the "Image" tab. You can zoom in and out of the image using 

your mouse wheel; the zoom will be centered around the position of your cursor.  

• Point detection: Detect the grid points in the image by clicking the "Detect" button in the "Detection & 

analysis" (2) section. 

Detection is finished when the progress bar at the bottom of the window (5) reaches 100%. By clicking 

"Show Detected Grid" under the image tab, you can display a visualization of the detected points.  

 

If auto-detection fails, you can make a manual ROI selection by setting the checkmark in the "Detection 

& analysis" section (2). Five preset ROIs will then appear in the visualized image.  

The size and position of these ROIs are adjustable by click ing and dragging.  

 

One ROI must be positioned on the 0th diffraction order (the brightest point in the center of the grid). 

Adjust the ROI size so that it contains only one point.  

The four remaining ROIs must be positioned on the points closest to the 0 th diffraction order, i.e., the one 

above, below, and to the left and right. These four ROIs may also only contain one point. Furthermore, 

Figure 7: Software user interface overview 
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the individual ROIs should not significantly overlap. See Figure 8 below for reference. 

 

 

 

• Analysis: After detection, the actual analysis can be performed. Click on the "Analyze" button in the 

"Detection & analysis" section (2) to start the calibration. The progress bar (5) indicates when the 

calibration is finished.  

Depending on the number of points detected, the time needed for calibration may vary  slightly. 

• Calibration results: the results will be listed under the "Result table" tab in the "Image" section (4). 

Please find an explanation of the values in chapter 4.2 of this manual. The RMSE of the calibration is 

also included in the result table. You can clear the result table if needed by clicking "clear table." 

Under the tab "Distortion curve," you also get a graphical visualization of the determined distortion of the 

camera (Geometric Distortion vs. Field). 

• Generate HDR image: Set the exposure times for every HDR image data (6). Choose an algorithm 

(Mertens, Debevec or Robertson) for the generation and click the “Generate HDR” button (7).  A subfolder 

“HDR” is generated in the HDR image data folder, in which all generated images will be saved.  

 

 

 

5.7 Saving results 

You have the option to either save your results to an XML or CSV-type f ile. If  you have analyzed multiple 

images, select one or multiple images you would like to save the results from the list in the "Image data" section. 

Then click File → Save result → Save XML or Save CSV → navigate to the desired location → click Save 

If  you selected multiple images, all results would be saved in one CSV or XML f ile.  

Figure 8: Manual point detection 
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5.8 Export Grids  

You can export three different grids, which are saved in CSV files. For each exported grid, two f iles are saved, 

one for the x and one for the y coordinates.  

To export a grid, click File  → Save grid → choose the desired grid → navigate to the desired location → click 

Save.  

Available grids:  

- Detected grid: Describes the grid type containing the detected light points.   

- Reprojected grid: Describes the grid type that contains the reprojected light points used to determine 

the distortion. 

- Undistorted reference grid: Describes the grid type, which contains the points of  the reference grid 

without lens distortion. This grid includes only distortion given by the DOE physics and the 

determined extrinsic and intrinsic parameters. 

5.9 Plotting 

There are several plots available: 

5.9.1 Grid view 

After a successful analysis, the detected and reprojected points are displayed on the original image. Zoom into 

the image for a clearer view. The points have a size of  one pixel. 

5.9.2 Distortion curve  

The curve is calculated f rom the distortion coef f icients and shows the grid of  the analyzed distortion.  

5.9.3 Quiver plot 

The quiver plot shows the direction of deviation. The respective arrows indicate how the detected points are 

located concerning the reprojected points. 

5.9.4 2d color scatter 

This plot shows a grid of color-coded points, with each point representing the distance ratio between detected 

and reprojected points. The scalar on the right side shows the individual color coding.  

5.9.5 Histogram 

Two dif ferent histograms are shown. The f irst histogram contains the successfully detected dif f raction points 

dependent on the radius. The values start at zero (principal point) and run along the image diagonal to the image 

corner (one). 
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The second histogram contains the successfully detected diffraction points dependent on the angle. The values 

start f rom a straight line defined from the principal point to the right edge of  the image. The angles increase 

counterclockwise. 

 

5.10 Logging 

The browser displays logging data for each action in the "Logging" section of the user interface. If errors occur, 

this can be helpful. The software also has a status bar at the bottom, where error messages from the API are 

displayed directly.  

 

5.11 Quit 

Click File (Quit (Ctrl+q) to exit the software or close the window. 

 

 

5.12 TRADEMARK AND COPYRIGHT 

 

Trademarks 

Windows is a registered trademark of  Microsof t Corp. 

 

Copyright Information  

See separate Terms and Conditions document. 
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6 ADDITIONAL INFORMATION 

 

6.1 Disposal instructions  

After the service life of GEOCAL/GEOCAL XL, it must be disposed of properly. Electrical and electromechanical 

components are included in GEOCAL/GEOCAL XL. Observe all national regulations. Ensure that third parties 

cannot use GEOCAL/GEOCAL XL af ter disposing of  it.  

Contact Image Engineering if  assistance for disposal is required.  

 

6.2 Power circuit modification for production line use 

If  you plan to use your GEOCAL/GEOCAL XL on a production line, we offer the option of  modifying the unit to 

eliminate the need to press the switch to turn it on and off. After the modification, moving the switch to the "ON" 

position is sufficient. The unit will immediately start operating when power is supplied without having to press the 

switch again. 

For more information on this option, please contact Image Engineering.  

7 TECHNICAL DATA SHEET           

See the website of  Image Engineering: https://image-engineering.de/support/downloads. 

 

https://image-engineering.de/support/downloads

